A-A+

解决安装HP打印机驱动CUPSEXT的问题

2012年11月08日 硬件配置 评论 2 条 阅读 13,620 views 次

在Linux下,支持最好的打印设备品牌首推HP。

小编由于爱屋及乌的关系,对HP也是推崇备至。之前在网易免费博客写过关于如何在Linux下驱动HP Deskjet 2050 打印复印扫描喷墨一体机。自Ubuntu11.04开始,Ubuntu(Linuxmint)即已自带了HP的开源驱动hplip,支持很多型号的HP打印设备。

Ubuntu自带HP打印机开源驱动hplip

HPLIP (HP Linux Imaging and Printing)是一个惠普公司发起和领导的项目,其目标是让Linux系统,能够完成支持惠普的喷墨打印机和激光打印机的打印,扫描和传真功能。它所提供的驱动程序,共支持1980部HP打印机型号。[本节引自维基百科]。HPLIP官网在这里

不过,硬件设备的更新也是日新月异的,Ubuntu12.04自带的hplip版本稍微旧了,很多新型号的打印机无法支持,比如小编办公室最近购买的HP Laserjet P1108激光打印机。P1108是一款不错的小型激光打印机,有一个卖点很吸引人:在Windows下,一连接数据线,P1108内置的驱动程序会自动安装,无需驱动光盘。可惜在Linux下还不行,还得安装hplip驱动。

小编在hplip官网下载了最新的hplip驱动,按照之前的方法安装,却提示:
CUPSEXT could not be loaded. Please check HPLIP installation.如图。

经过一番google,在国外网站找到了解决办法,只需安装以下软件即可。在终端安装:

sudo apt-get install hplip-gui hplip hplip-cups hplip-data hpijs hpijs-ppds

然后再安装hplip,就没问题啦。如图。

安装HP打印机开源驱动hplip

HP Laserjet P1108激光打印机顺利驱动成功,效果与Windows无异。关于hplip的安装方法,可以参阅小编网易博客的文章:
Ubuntu完美驱动HP Deskjet 2050喷墨一体机

Ubuntu/Linuxmint完美驱动HP打印机--全图版

值得注意的是,现在很多HP打印机(主要是激光打印机),除了安装hplip外,还得安装plugin驱动插件,在hplip的配置程序里有自动下载功能,需要联网下载,也可以到OpenPrinting网站下载与hplip版本对应的驱动插件。如小编现在用的是hplip-3.12.11,那么下载hplip-3.12.11-plugin.run。下载后,在终端中以管理员身份运行即可安装,sudo sh hplip-3.12.11-plugin.run。也可以在HPLIP设备管理器中用鼠标添加。

看看小编把HP Laserjet P1108激光打印机驱动成功的截图。这是hplip的任务托盘。

Ubuntu使用hplip驱动HP P1108激光打印机

这就是HPLIP的设备管理器。

在Linux下使用HPLIP驱动HP P1108打印机

这是在WPS for Linux中的打印机选择,使用WPS for Linux打印了几篇文档,完美支持。

Ubuntu使用hplip驱动HP P1108激光打印机

  1. 建议 改变一下网站布局

    还有配色

    这个网站的内容非常好。但

    logo有点山寨哦

Copyright © 薄荷开源网 保留所有权利.   Theme  Ality

用户登录

分享到: