A-A+

HPLIP:LinuxMint/Ubuntu驱动HP打印机的注意事项

2013年11月21日 硬件配置 评论 5 条 阅读 16,685 views 次

HPLIP (HP Linux Imaging and Printing) 是一个惠普公司发起和领导的项目,其目标是让 Linux 系统,能够完成支持惠普的喷墨打印机和激光打印机的打印,扫描和传真功能。它所提供的驱动程序,共支持1980部HP打印机型号。

薄荷开源网小编之前两度介绍了关于如何在 Linux Mint / Ubuntu 下驱动 HP 惠普打印机。其实,Linux 一路走来,凭着众多充满自由、共享和奉献精神的黑客们的努力,在 Windows 及其利益生态构筑的坚固混沌中,杀出一条血路来,真令人钦佩!尤其在现实利益面前(桌面用户太少),很多硬件厂商都没有为 Linux 开发驱动程序。而惠普却难能可贵,支持了 HPLIP 项目,使得其打印机在 Linux 支持良好。光凭这一点,从小编个人情感来讲,是绝对支持惠普的。从小编的使用经验来讲,也推荐朋友们尽量购买、使用惠普的打印机。

Linux Mint / Ubuntu 软件源中都有 hplip(版本稍旧),安装起来非常方便。而 Linux Mint 更是已经搭载了 hplip,对于一般的喷墨打印机,比如 hp deskjet 1000/2050  等,可谓真正的即插即用。只要连接好打印机的数据线,系统会自动添加打印机,数秒即可完成,并且马上可以打印了。而对于多数激光打印机和较新的型号,需要到 hplip 官网下载最新版的 hplip 和 hplip-plugin(插件)才能驱动起来。

hplip 下载地址

hplip-plugin 下载地址
hplip的安装虽然是在终端中进行,但属于向导式的,也很容易懂,请参阅《Ubuntu/Linuxmint完美驱动HP打印机》。本文中,小编主要介绍一下常见问题和注意事项:

注意1
下载同版本的hplip及其插件,比如最新版的是hplip-3.13.11.run,那么匹配的插件就是hplip-3.13.11-plugin.run。如图所示。

注意2
正确使用安装命令。
a.安装hplip,使用普通用户权限可,不要用sudo。使用普通用户权限运行hplip安装程序过程中,hplip会要求用户输入root密码。即在终端中运行sh hplip-3.13.11.run即可。

b.确保hplip正确安装后(有问题见下文),再安装hplip-plugin,如图所示,安装hlip-plugin需要sudo权限,勾选同意协议后,点击“next”即可安装完毕,非常简单。

注意3
正确安装依赖软件。
a.如果在安装hplip过程中,遇到下图所示的“cups-image”依赖软件问题,请在终端中先安装如下软件,再运行hplip安装程序:
sudo apt-get install hpijs hpijs-ppds hplip-cups

b.如果遇到的出错提示是“CUPSEXT could not be loaded. Please check HPLIP installation.”,请在终端中先安装如下软件,再运行hplip安装程序:(参阅《Ubuntu安装hplip驱动解决cupsext问题》
sudo apt-get install hplip-gui hplip hplip-cups hplip-data hpijs hpijs-ppds libcupsimage2-dev

注意4
安装成功后无法启动HP Device Manager(惠普设备管理器及托盘小图标),可以在终端中运行hp-systray,查看出错信息。如图所示,出错信息提示hplip的配置文件夹中的锁定文件无法打开。

我们打开主目录,显示隐藏文件,可以看到hplip及附带的sane扫描程序的配置文件夹都是没有读写权限的。这是由于“注意2”中所讲的,使用sudo安装hplip所导致的问题。

既然没有读写权限,用命令赋予它读写权限即可。如图所示,将hplip和sane的配置文件夹都设置为可读写执行完整权限。

此时,再运行hp-systray或者HP Device Manager,就没问题了。

其实只要掌握了以上技巧,安装安装hplip及其插件,比起在Windows下驱动打印机需要放入光盘,耗时很长、安装一大堆软件而言,hplip简直太好用啦!薄荷开源网小编在此疾呼:支持Linux,支持HPLIP,支持惠普!

  1. 惠普打印机的耗材很贵,其实EPSON的设备在安装了驱动后也能在Linux中使用。这个随人喜好。说实话EPSON的墨仓式打印机很划算,耗材成本低。首先声明我不是Tuo!

    • 开源界的CUPS项目本身确实自带了很多打印机的驱动,当然也包括部分EPSON的型号。我特别赞许HP,并不是因为其产品本身,而是基于其对Linux的重视和支持。

      至于耗材贵与平,我在单位用的基本上都是HP的,好像也没觉得贵吧?呵呵

  2. 报告一个技巧:如果执行plugin不成功,可以在HPLIP控制台里点InstallRequiredPlugin然后选第二项,选择你自己下载的版本一致的plugin(如果路径框变成白色说明选对了),一路next即可

Copyright © 薄荷开源网 保留所有权利.   Theme  Ality

用户登录

分享到: